]> git.decadent.org.uk Git - nfs-utils.git/commitdiff
Imported Debian patch 1.0.9-10 debian/1%1.0.9-10
authorSteinar H. Gunderson <sesse@debian.org>
Sat, 26 Aug 2006 01:29:09 +0000 (03:29 +0200)
committerBen Hutchings <ben@decadent.org.uk>
Wed, 14 Jul 2010 01:37:22 +0000 (02:37 +0100)
debian/changelog
debian/control
utils/mountd/mountd.c

index 600b004944a0d6a45b12082f53ae556a8ed095d6..b0e9f46a48e765b4ef262e425e07da1aa5dc70d6 100644 (file)
@@ -1,3 +1,14 @@
+nfs-utils (1:1.0.9-10) unstable; urgency=low
+
+  * The -n option (short option for --no-tcp) to rpc.mountd was set
+    to take a parameter, even though --no-tcp doesn't take any, the
+    parameter is never used and the help doesn't mention any. Remove
+    the colon after 'n' in the getopt string to fix it.
+  * Add a versioned dependency from nfs-common to libnfsidmap1 (>= 0.16-3)
+    temporarily, to work around #384688.
+
+ -- Steinar H. Gunderson <sesse@debian.org>  Sat, 26 Aug 2006 03:29:09 +0200
+
 nfs-utils (1:1.0.9-9) unstable; urgency=medium
 
   * Patched svc_socket.c to define __bzero only on ia64.
index 7430755060369c135f3a801c2bf66f254d5d56d8..b25ecd789a7be3a397e105faea72c15b346dcfae 100644 (file)
@@ -24,7 +24,7 @@ Description: Kernel NFS server support
 
 Package: nfs-common
 Architecture: any
-Depends: portmap, sysvinit (>= 2.80-1), adduser, ucf, lsb-base (>= 1.3-9ubuntu3), ${shlibs:Depends}
+Depends: portmap, sysvinit (>= 2.80-1), adduser, ucf, lsb-base (>= 1.3-9ubuntu3), ${shlibs:Depends}, libnfsidmap1 (>= 0.16-3)
 Provides: nfs-client
 Conflicts: nfs-client
 Replaces: nfs-client, nfs-kernel-server (<< 1:1.0.7-5)
index c1d18d4cebc9b37b1f227d7de33fe1aaf4ccfaaf..f40d3673792e39551d331c32ece94873118a531a 100644 (file)
@@ -558,7 +558,7 @@ main(int argc, char **argv)
 
        /* Parse the command line options and arguments. */
        opterr = 0;
-       while ((c = getopt_long(argc, argv, "o:n:Fd:f:p:P:hH:N:V:vs:t:", longopts, NULL)) != EOF)
+       while ((c = getopt_long(argc, argv, "o:nFd:f:p:P:hH:N:V:vs:t:", longopts, NULL)) != EOF)
                switch (c) {
                case 'o':
                        descriptors = atoi(optarg);