]> git.decadent.org.uk Git - nfs-utils.git/commitdiff
Imported Debian patch 1.0.7-8 debian/1%1.0.7-8
authorSteinar H. Gunderson <sesse@debian.org>
Wed, 5 Apr 2006 20:54:09 +0000 (22:54 +0200)
committerBen Hutchings <ben@decadent.org.uk>
Tue, 13 Jul 2010 03:04:29 +0000 (04:04 +0100)
confdefs.h [deleted file]
debian/changelog
support/nfs/exports.c
utils/mountd/mountd.c
utils/mountd/mountd.man

diff --git a/confdefs.h b/confdefs.h
deleted file mode 100644 (file)
index 0010349..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-
-#define NFS3_SUPPORTED 1
-#define NFS4_SUPPORTED 1
-#define GSS_SUPPORTED 1
index a36dd98ee659abca9bf8486b618c33e19d83c769..bbb9d2991b1dcf2694ae3bfbd66a5cf30586426c 100644 (file)
@@ -1,3 +1,13 @@
+nfs-utils (1:1.0.7-8) unstable; urgency=low
+
+  * Don't complain about missing sync/async for a read-only export.
+    (Closes: #265409)
+  * Implement --state-directory-path for rpc.mountd; most code borrowed
+    from rpc.statd. (Closes: #352387)
+    * Update mountd.man accordingly.
+
+ -- Steinar H. Gunderson <sesse@debian.org>  Wed,  5 Apr 2006 22:54:09 +0200
+
 nfs-utils (1:1.0.7-7) unstable; urgency=high
 
   * urgency=high, fixes an RC bug.
index 1e3854b9d0846a0ba557b64c1ddb91e0cbe4bb9c..7194c08e20b20652196565fbefc859470b8ac510 100644 (file)
@@ -448,7 +448,7 @@ bad_option:
        ep->e_nsqgids = nsqgids;
 
 out:
-       if (warn && !had_sync_opt)
+       if (warn && !had_sync_opt && !(ep->e_flags & NFSEXP_READONLY))
                xlog(L_WARNING, "%s [%d]: No 'sync' or 'async' option specified for export \"%s:%s\".\n"
                                "  Assuming default behaviour ('sync').\n"
                                "  NOTE: this default has changed from previous versions\n",
index 14dac4185c32e9483f108a7faccdc9811ff0f3c1..a2ecb98c55b320642ecec42f2cf865608d124203 100644 (file)
@@ -54,6 +54,7 @@ static struct option longopts[] =
        { "port", 1, 0, 'p' },
        { "no-tcp", 0, 0, 'n' },
        { "ha-callout", 1, 0, 'H' },
+       { "state-directory-path", 1, 0, 's' },
        { NULL, 0, 0, 0 }
 };
 
@@ -441,6 +442,7 @@ int
 main(int argc, char **argv)
 {
        char    *export_file = _PATH_EXPORTS;
+       char    *state_dir = NFS_STATEDIR;
        int     foreground = 0;
        int     port = 0;
        int     descriptors = 0;
@@ -490,6 +492,13 @@ main(int argc, char **argv)
                case 'n':
                        _rpcfdtype = SOCK_DGRAM;
                        break;
+               case 's':
+                       if ((state_dir = xstrdup(optarg)) == NULL) {
+                               fprintf(stderr, "%s: xstrdup(%s) failed!\n",
+                                       argv[0], optarg);
+                               exit(1);
+                       }
+                       break;
                case 'V':
                        nfs_version |= 1 << (atoi (optarg) - 1);
                        break;
@@ -507,9 +516,9 @@ main(int argc, char **argv)
        if (optind != argc || !(nfs_version & 0x7))
                usage(argv [0], 1);
 
-       if (chdir(NFS_STATEDIR)) {
+       if (chdir(state_dir)) {
                fprintf(stderr, "%s: chdir(%s) failed: %s\n",
-                       argv [0], NFS_STATEDIR, strerror(errno));
+                       argv [0], state_dir, strerror(errno));
                exit(1);
        }
 
@@ -606,6 +615,6 @@ usage(const char *prog, int n)
 "      [-o num|--descriptors num] [-f exports-file|--exports-file=file]\n"
 "      [-p|--port port] [-V version|--nfs-version version]\n"
 "      [-N version|--no-nfs-version version] [-n|--no-tcp]\n"
-"      [-H ha-callout-prog]\n", prog);
+"      [-H ha-callout-prog] [-s|--state-directory-path path]\n", prog);
        exit(n);
 }
index 64e508a26ea2768ad39ca98e4384b9c36162105f..a815a52d66cdf6c6539054dc96f33fe76032ecb3 100644 (file)
@@ -119,6 +119,12 @@ The third will be the path that the client is mounting.
 The last is the number of concurrent mounts that we believe the client
 has of that path.
 .TP
+.BI "\-P," "" " \-\-state\-directory\-path "  directory
+specify a directory in which to place statd state information.
+If this option is not specified the default of 
+.BR /var/lib/nfs
+is used. (This is a Debian-specific extension.)
+.TP
 .B \-V " or " \-\-nfs-version
 This option can be used to request that
 .B rpc.mountd