]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - utils/rquotad/Makefile.am
Add --with-rpcgen= for configure so that the system rpcgen can be used.
[nfs-utils.git] / utils / rquotad / Makefile.am
index dcc15ac9c4aad1c85d140b486ab8136cabb658c6..4bc036fca080d398e34ebb3863c353f58357c84f 100644 (file)
@@ -1,6 +1,5 @@
 ## Process this file with automake to produce Makefile.in
 
-RPCGEN         = $(top_builddir)/tools/rpcgen/rpcgen
 
 GENFILES_XDR   = rquota_xdr.c
 GENFILES_H     = rquota.h
@@ -27,9 +26,13 @@ rquotad_CPPFLAGS = $(AM_CPPFLAGS) $(CPPFLAGS) \
 
 MAINTAINERCLEANFILES = Makefile.in
 
-
+if CONFIG_RPCGEN
+RPCGEN         = $(top_builddir)/tools/rpcgen/rpcgen
 $(RPCGEN):
        make -C $(top_srcdir)/tools/rpcgen all
+else
+RPCGEN = @RPCGEN_PATH@
+endif
 
 $(GENFILES_XDR): %_xdr.c: %.x $(RPCGEN)
        test -f $@ && rm -rf $@ || true