]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - utils/lockd/Makefile.am
Remove rpc.lockd
[nfs-utils.git] / utils / lockd / Makefile.am
diff --git a/utils/lockd/Makefile.am b/utils/lockd/Makefile.am
deleted file mode 100644 (file)
index e1546a4..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-## Process this file with automake to produce Makefile.in
-
-man8_MANS      = lockd.man
-EXTRA_DIST     = $(man8_MANS)
-
-RPCPREFIX      = rpc.
-KPREFIX                = @kprefix@
-sbin_PROGRAMS  = lockd
-lockd_SOURCES = lockd.c
-lockd_LDADD = ../../support/export/libexport.a \
-             ../../support/nfs/libnfs.a \
-             ../../support/misc/libmisc.a
-
-MAINTAINERCLEANFILES = Makefile.in
-
-#######################################################################
-# The following allows the current practice of having
-# daemons renamed during the install to include RPCPREFIX
-# and the KPREFIX
-# This could all be done much easier with program_transform_name
-# ( program_transform_name = s/^/$(RPCPREFIX)$(KPREFIX)/ )
-# but that also renames the man pages, which the current
-# practice does not do.
-install-exec-hook:
-       (cd $(DESTDIR)$(sbindir) && \
-         for p in $(sbin_PROGRAMS); do \
-           mv -f $$p$(EXEEXT) $(RPCPREFIX)$(KPREFIX)$$p$(EXEEXT) ;\
-         done)
-uninstall-hook:
-       (cd $(DESTDIR)$(sbindir) && \
-         for p in $(sbin_PROGRAMS); do \
-           rm -f $(RPCPREFIX)$(KPREFIX)$$p$(EXEEXT) ;\
-         done)
-
-
-# XXX This makes some assumptions about what automake does.
-# XXX But there is no install-man-hook or install-man-local.
-install-man: install-man8 install-man-links
-uninstall-man: uninstall-man8 uninstall-man-links
-
-install-man-links:
-       (cd $(DESTDIR)$(man8dir) && \
-         for m in $(man8_MANS) $(dist_man8_MANS) $(nodist_man8_MANS); do \
-           inst=`echo $$m | sed -e 's/man$$/8/'`; \
-           rm -f $(RPCPREFIX)$$inst ; \
-           $(LN_S) $$inst $(RPCPREFIX)$$inst ; \
-         done)
-
-uninstall-man-links:
-       (cd $(DESTDIR)$(man8dir) && \
-         for m in $(man8_MANS) $(dist_man8_MANS) $(nodist_man8_MANS); do \
-           inst=`echo $$m | sed -e 's/man$$/8/'`; \
-           rm -f $(RPCPREFIX)$$inst ; \
-         done)
-