]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - utils/Makefile.am
mountd: Use static buffer when constructing junction export options
[nfs-utils.git] / utils / Makefile.am
index 79f1270bf15cd9af5470fa060ed5d1fa3bf2e2de..09045dd6a85c8d06bc92737cdcef9fc9f4bae479 100644 (file)
@@ -2,27 +2,37 @@
 
 OPTDIRS =
 
-if CONFIG_RQUOTAD
-OPTDIRS += rquotad
-endif
-
 if CONFIG_NFSV4
 OPTDIRS += idmapd
+if CONFIG_NFSIDMAP
+OPTDIRS += nfsidmap
+endif
+endif
+
+if CONFIG_NFSV41
+OPTDIRS += blkmapd
 endif
 
 if CONFIG_GSS
-OPTDIRS += gssd svcgssd
+OPTDIRS += gssd
+endif
+
+if CONFIG_MOUNT
+OPTDIRS += mount
+endif
+
+if CONFIG_NFSDCLD
+OPTDIRS += nfsdcld
 endif
 
 SUBDIRS = \
        exportfs \
-       lockd \
        mountd \
        nfsd \
        nfsstat \
-       nhfsstone \
        showmount \
        statd \
+       osd_login \
        $(OPTDIRS)
 
 MAINTAINERCLEANFILES = Makefile.in