]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - support/export/Makefile.am
libexport.a: Allow client_init() to fail instead of exit
[nfs-utils.git] / support / export / Makefile.am
index 7a6a441c6c2f508135609a1b60e583c557dcf182..1ea15397c3a99ef76bb3dc906f3fa48ba9342d91 100644 (file)
@@ -1,6 +1,5 @@
 ## Process this file with automake to produce Makefile.in
 
-RPCGEN         = $(top_builddir)/tools/rpcgen/rpcgen
 
 GENFILES_CLNT  = mount_clnt.c
 GENFILES_XDR   = mount_xdr.c
@@ -22,8 +21,13 @@ dist-hook:
          rm ${distdir}/$$f; \
        done
 
+if CONFIG_RPCGEN
+RPCGEN         = $(top_builddir)/tools/rpcgen/rpcgen
 $(RPCGEN):
        make -C $(top_srcdir)/tools/rpcgen all
+else
+RPCGEN = @RPCGEN_PATH@
+endif
 
 $(GENFILES_CLNT): %_clnt.c: %.x $(RPCGEN)
        test -f $@ && rm -rf $@ || true