]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - debian/rules
Imported Debian patch 1.0.10-2
[nfs-utils.git] / debian / rules
index 70877a89783693029880ab6cd6471faae7595c95..8eba169cf8cd367940043ffb15816c20e5d43f06 100755 (executable)
@@ -1,31 +1,23 @@
 #!/usr/bin/make -f
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 
-export DH_VERBOSE=1
+DEB_BUILD_GNU_TYPE     := $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_HOST_GNU_TYPE      := $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_HOST_ARCH          := $(shell dpkg-architecture -qDEB_HOST_ARCH)
+DEB_HOST_ARCH_OS       := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
 
 # Temporary root
 DEBTMP := $(shell pwd)/debian/tmp
 
 build: build-stamp
 build-stamp:
-       # Debian source diffs don't reflect removals.
-       # This kludge will suffice until the next upstream version. *sigh*
-       rm -f debian/nfs-common.conffiles       \
-             debian/nfs-common.config          \
-             debian/nfs-common.files           \
-             debian/nfs-common.templates       \
-             debian/nfs-kernel-server.conffiles\
-             debian/nfs-kernel-server.config   \
-             debian/nfs-kernel-server.templates\
-             debian/nhfsstone.files
-
        dh_testdir
-       -test -r /usr/share/misc/config.sub && cp -f /usr/share/misc/config.sub config.sub
-       -test -r /usr/share/misc/config.guess && cp -f /usr/share/misc/config.guess config.guess
-       autoconf
-       ./configure \
+ifeq ($(DEB_HOST_ARCH),ia64)
+       patch -p1 < debian/bzero.patch
+endif
+       CFLAGS="-g -O2 -Wall" ./configure \
                --mandir='$${prefix}/share/man' \
-               --enable-secure-statd
+               --enable-secure-statd 
        $(MAKE)
        touch build-stamp
 
@@ -34,11 +26,7 @@ clean:
        dh_testroot
        rm -f build-stamp
        rm -rf $(DEBTMP)
-       # Add here commands to clean up after the build process.
-       -test -r /usr/share/misc/config.sub && rm -f config.sub
-       -test -r /usr/share/misc/config.guess && rm -f config.guess
        -$(MAKE) distclean
-       rm -f config.log configure
        dh_clean
 
 binary-indep: build
@@ -48,22 +36,19 @@ binary-arch: build
        dh_clean -k
        dh_installdirs
        mkdir $(DEBTMP)
-       # Add here commands to install the files into debian/tmp
-       $(MAKE) install_prefix='$(DEBTMP)' install
-       dh_install --sourcedir=debian/tmp/
-       # Fixups Start Here #
-       cd debian && \
-         for f in lockd statd showmount; do \
-           perl -pi -e "s#/usr(/sbin/(rpc\\.)?$$f)#\$$1#g" \
-               nfs-common/usr/share/man/man8/$$f.8; \
-         done; \
-         cp --preserve=timestamps etc.exports nfs-kernel-server/etc/exports; \
-         cp --preserve=timestamps idmapd.conf nfs-common/etc/; \
-         cp --preserve=timestamps gssapi_mech.conf nfs-common/etc/; \
-       # Fixups End Here #
+       $(MAKE) DESTDIR='$(DEBTMP)' install
+       dh_install
+       
+       # Fix up the manpages
+       for f in lockd statd showmount; do \
+         perl -pi -e "s#/usr(/sbin/(rpc\\.)?$$f)#\$$1#g" \
+           debian/tmp/usr/share/man/man8/$$f.8; \
+       done;
+       
        dh_installdocs -A
-       dh_installexamples
-       dh_installinit -n
+       dh_installdocs -pnfs-common debian/README.Debian.nfsv4
+       install -m 0755 debian/nfs-common.init debian/nfs-common/etc/init.d/nfs-common
+       install -m 0755 debian/nfs-kernel-server.init debian/nfs-kernel-server/etc/init.d/nfs-kernel-server
        dh_installman
        dh_link
        dh_installchangelogs ChangeLog