]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - debian/rules
Imported Debian patch 1.0.10-2
[nfs-utils.git] / debian / rules
index 0c5b9dea7ae9bcd077bf045614651b254bdba6c5..8eba169cf8cd367940043ffb15816c20e5d43f06 100755 (executable)
@@ -1,7 +1,10 @@
 #!/usr/bin/make -f
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 
-export DH_VERBOSE=1
+DEB_BUILD_GNU_TYPE     := $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_HOST_GNU_TYPE      := $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_HOST_ARCH          := $(shell dpkg-architecture -qDEB_HOST_ARCH)
+DEB_HOST_ARCH_OS       := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
 
 # Temporary root
 DEBTMP := $(shell pwd)/debian/tmp
@@ -9,11 +12,12 @@ DEBTMP       := $(shell pwd)/debian/tmp
 build: build-stamp
 build-stamp:
        dh_testdir
-       -test -r /usr/share/misc/config.sub && cp -f /usr/share/misc/config.sub config.sub
-       -test -r /usr/share/misc/config.guess && cp -f /usr/share/misc/config.guess config.guess
-       ./configure \
+ifeq ($(DEB_HOST_ARCH),ia64)
+       patch -p1 < debian/bzero.patch
+endif
+       CFLAGS="-g -O2 -Wall" ./configure \
                --mandir='$${prefix}/share/man' \
-               --enable-secure-statd
+               --enable-secure-statd 
        $(MAKE)
        touch build-stamp