]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - debian/rules
Imported Debian patch 1.0.11~git-20070212-1
[nfs-utils.git] / debian / rules
index 8eba169cf8cd367940043ffb15816c20e5d43f06..40a2daf4b996a6ae63228b8954427c64e3a7824f 100755 (executable)
@@ -1,27 +1,21 @@
-#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
+#! /usr/bin/make -f
 
-DEB_BUILD_GNU_TYPE     := $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-DEB_HOST_GNU_TYPE      := $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_HOST_ARCH          := $(shell dpkg-architecture -qDEB_HOST_ARCH)
-DEB_HOST_ARCH_OS       := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+include /usr/share/quilt/quilt.make
 
 # Temporary root
-DEBTMP := $(shell pwd)/debian/tmp
+DEBTMP := $(CURDIR)/debian/tmp
 
-build: build-stamp
+build: patch build-stamp
 build-stamp:
        dh_testdir
-ifeq ($(DEB_HOST_ARCH),ia64)
-       patch -p1 < debian/bzero.patch
-endif
        CFLAGS="-g -O2 -Wall" ./configure \
                --mandir='$${prefix}/share/man' \
-               --enable-secure-statd 
+               --enable-secure-statd \
+               --with-tcp-wrappers
        $(MAKE)
        touch build-stamp
 
-clean:
+clean: unpatch
        dh_testdir
        dh_testroot
        rm -f build-stamp
@@ -38,13 +32,6 @@ binary-arch: build
        mkdir $(DEBTMP)
        $(MAKE) DESTDIR='$(DEBTMP)' install
        dh_install
-       
-       # Fix up the manpages
-       for f in lockd statd showmount; do \
-         perl -pi -e "s#/usr(/sbin/(rpc\\.)?$$f)#\$$1#g" \
-           debian/tmp/usr/share/man/man8/$$f.8; \
-       done;
-       
        dh_installdocs -A
        dh_installdocs -pnfs-common debian/README.Debian.nfsv4
        install -m 0755 debian/nfs-common.init debian/nfs-common/etc/init.d/nfs-common