]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - debian/rules
Imported Debian patch 1.0.11~git-20070212-1
[nfs-utils.git] / debian / rules
index 4c8834b9a972912d7581f23fab1e91b3b357b29b..40a2daf4b996a6ae63228b8954427c64e3a7824f 100755 (executable)
@@ -1,87 +1,52 @@
-#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
+#! /usr/bin/make -f
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-# You can use gcc 2.7.2 if it's installed,
-#   but I don't think that's necessary any more.
-#SETGCC        := CC=$(notdir $(shell which gcc272 gcc 2>/dev/null | sed '1q'))
+include /usr/share/quilt/quilt.make
 
 # Temporary root
-DEBTMP := $(shell pwd)/debian/tmp
+DEBTMP := $(CURDIR)/debian/tmp
 
-build: build-stamp
+build: patch build-stamp
 build-stamp:
-       # Debian source diffs don't reflect removals.
-       # This kludge will suffice until the next upstream version. *sigh*
-       rm -f debian/nfs-common.config          \
-             debian/nfs-common.templates       \
-             debian/nfs-kernel-server.config   \
-             debian/nfs-kernel-server.templates
-
        dh_testdir
-       # Add here commands to compile the package.
-       $(SETGCC) ./configure \
+       CFLAGS="-g -O2 -Wall" ./configure \
                --mandir='$${prefix}/share/man' \
-               --enable-secure-statd
+               --enable-secure-statd \
+               --with-tcp-wrappers
        $(MAKE)
        touch build-stamp
 
-clean:
+clean: unpatch
        dh_testdir
        dh_testroot
        rm -f build-stamp
-       # Add here commands to clean up after the build process.
+       rm -rf $(DEBTMP)
        -$(MAKE) distclean
        dh_clean
 
-# Build architecture-independent files here.
 binary-indep: build
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
 binary-arch: build
        dh_testdir
        dh_testroot
        dh_clean -k
        dh_installdirs
-       # Add here commands to install the files into debian/tmp
-       $(MAKE) install_prefix='$(DEBTMP)' install
-       dh_movefiles
-       # Fixups Start Here #
-       cd debian && \
-         for f in lockd statd showmount; do \
-           mv tmp/usr/sbin/*$$f nfs-common/sbin; \
-           perl -pi -e "s#/usr(/sbin/(rpc\\.)?$$f)#\$$1#g" \
-               nfs-common/usr/share/man/man8/$$f.8; \
-         done; \
-         rm -f tmp/usr/sbin/*quota*; \
-         rm -f tmp/usr/share/man/man8/*quota*; \
-         rm -rf tmp/var/lib/nfs/*; \
-         cp --preserve=timestamps etc.exports tmp/etc/exports
-       # Fixups End Here #
-       dh_installdocs -A README
-       dh_installexamples
-#      dh_installmenu
-       dh_installinit -n
-#      dh_installcron
-#      dh_installmanpages
-#      dh_undocumented
+       mkdir $(DEBTMP)
+       $(MAKE) DESTDIR='$(DEBTMP)' install
+       dh_install
+       dh_installdocs -A
+       dh_installdocs -pnfs-common debian/README.Debian.nfsv4
+       install -m 0755 debian/nfs-common.init debian/nfs-common/etc/init.d/nfs-common
+       install -m 0755 debian/nfs-kernel-server.init debian/nfs-kernel-server/etc/init.d/nfs-kernel-server
+       dh_installman
+       dh_link
        dh_installchangelogs ChangeLog
        dh_strip
        dh_compress
        dh_fixperms
-       dh_installdebconf
        dh_installdeb
-#      dh_makeshlibs
        dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
-source diff:                                                                  
-       @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
-
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary