]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - debian/rules
Imported Debian patch 1.0.10-6~quilt.3
[nfs-utils.git] / debian / rules
index f3532ed877ad86f8d1dad63f78af42d50a10e308..26168cf9e72083e16dd4b986ae3a6244aa1be6bf 100755 (executable)
@@ -1,34 +1,26 @@
-#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
+#! /usr/bin/make -f
 
-export DH_VERBOSE=1
-
-DEB_BUILD_GNU_TYPE     := $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-DEB_HOST_GNU_TYPE      := $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_HOST_ARCH          := $(shell dpkg-architecture -qDEB_HOST_ARCH)
-DEB_HOST_ARCH_OS       := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+include /usr/share/quilt/quilt.make
 
 # Temporary root
 DEBTMP := $(shell pwd)/debian/tmp
 
 build: build-stamp
-build-stamp:
+build-stamp: patch
        dh_testdir
-ifeq ($(DEB_HOST_ARCH),ia64)
-       patch -p1 < debian/bzero.patch
-endif
-       CFLAGS="-g -Wall" ./configure \
+       CFLAGS="-g -O2 -Wall" ./configure \
                --mandir='$${prefix}/share/man' \
                --enable-secure-statd 
        $(MAKE)
        touch build-stamp
 
-clean:
+clean: unpatch
        dh_testdir
        dh_testroot
        rm -f build-stamp
        rm -rf $(DEBTMP)
        -$(MAKE) distclean
+       $(RM) utils/rquotad/rquota.h utils/rquotad/rquota_xdr.c
        dh_clean
 
 binary-indep: build
@@ -43,8 +35,8 @@ binary-arch: build
        
        # Fix up the manpages
        for f in lockd statd showmount; do \
-         perl -pi -e "s#/usr(/sbin/(rpc\\.)?$$f)#\$$1#g" \
-           debian/tmp/usr/share/man/man8/$$f.8; \
+               perl -pi -e "s#/usr(/sbin/(rpc\\.)?$$f)#\$$1#g" \
+                       debian/tmp/usr/share/man/man8/$$f.8; \
        done;
        
        dh_installdocs -A