]> git.decadent.org.uk Git - maypole.git/blobdiff - debian/rules
Fix build procedure; include full dependencies and run tests.
[maypole.git] / debian / rules
old mode 100644 (file)
new mode 100755 (executable)
index 864a189..2fd9adf
@@ -1,19 +1,20 @@
 #!/usr/bin/make -f
 
-build :
+build : build-stamp
+
+build-stamp : Makefile.PL
        perl Makefile.PL INSTALLDIRS=vendor
-       $(MAKE)
+       $(MAKE) test
+       touch build-stamp
 
 binary : binary-arch binary-indep
 
 binary-arch :
 
-binary-indep : build
+binary-indep : build-stamp
        dh_testroot
-       mkdir -p -m755 debian/libmaypole-perl/usr/share/perl5
        $(MAKE) PREFIX=$(CURDIR)/debian/libmaypole-perl/usr install
        dh_perl
-       mkdir -p -m755 debian/libmaypole-perl/usr/share/doc/libmaypole-perl
        dh_installchangelogs
        dh_installdocs
        dh_compress
@@ -23,6 +24,6 @@ binary-indep : build
 
 clean : 
        if [ -f Makefile ]; then $(MAKE) clean; fi
-       dh_clean Makefile
+       dh_clean Makefile Makefile.old build-stamp
 
 .PHONY : build binary binary-arch binary-dep clean