Override warning and error about using debconf in postinst not config
authorBen Hutchings <ben@decadent.org.uk>
Sat, 6 Jun 2009 19:30:32 +0000 (20:30 +0100)
committerBen Hutchings <ben@decadent.org.uk>
Sat, 13 Jun 2009 04:23:49 +0000 (05:23 +0100)
debian/changelog
debian/ion3.install
debian/overrides/ion3 [new file with mode: 0644]

index be458ad..55ec810 100644 (file)
@@ -4,6 +4,7 @@ ion3 (20090110-2) unstable; urgency=low
   * Fix/ignore issues reported by lintian:
     - Install libextl-mkexports as executable
     - Add ${misc:Depends} to ion3-dev
+    - Ignore necessary use of debconf in postinst
 
  -- Ben Hutchings <ben@decadent.org.uk>  Sat, 13 Jun 2009 05:17:15 +0100
 
index 8f7c28e..d2046fc 100644 (file)
@@ -3,3 +3,4 @@ debian/default etc
 debian/watch usr/share/ion3/debian
 debian/install-ion3-cfg usr/sbin
 debian/cfg_kludge_flash.lua etc/X11/ion3
+debian/overrides/ion3 usr/share/lintian/overrides
diff --git a/debian/overrides/ion3 b/debian/overrides/ion3
new file mode 100644 (file)
index 0000000..cd0081b
--- /dev/null
@@ -0,0 +1,4 @@
+# We prompt the user if this version is out of date.  The version check
+# requires uscan, so we do it in postinst rather than config.
+ion3: no-debconf-config
+ion3: postinst-uses-db-input